Problems with alert delivery
Incident Report for RescueTime, Inc
Resolved
We've identified and corrected the source of the issue causing duplicate alert delivery. Alerts should be working normally now and we are monitoring closely for any new issues.
Posted May 28, 2019 - 17:13 EDT
Investigating
Some users are receiving multiple copies of alerts delivered by email, mobile notification, or the desktop app. We have disabled alert delivery while we diagnose and fix the issue. Our engineers are currently investigating. We will keep you updated.
Posted May 27, 2019 - 17:53 EDT
This incident affected: RescueTime Web Application.