Slow Processors
Incident Report for RescueTime, Inc
Resolved
Happy to report, this has been resolved! Processors are running smoothly and things are back to normal. Please email support@rescuetime.com if you're experiencing differently.
Posted 3 months ago. Jul 01, 2019 - 10:08 EDT
Identified
Just a heads up! Our processors are running a bit slow. Our developers are currently working on getting things back up to speed. We will keep you updated when things are back to normal. Thank you for your patience!
Posted 3 months ago. Jul 01, 2019 - 09:55 EDT
This incident affected: Data Processors.