We're happy to report our developers have identified and resolved the issue. A temporary hardware fault caused a short window of downtime (7-10 minutes). We have recovered and the service is available again.
Posted Apr 15, 2019 - 10:28 EDT
Investigating
We are currently investigating 503 errors received when trying to access RescueTime.com. Thank you for your patience.
Posted Apr 15, 2019 - 10:11 EDT
This incident affected: RescueTime Web Application.