delayed data reporting

Incident Report for RescueTime, Inc

Resolved

This incident has been resolved. If you do still see missing data, it should be caught up very shortly.
Posted May 27, 2022 - 13:46 EDT

Identified

We are experiencing a slowdown in the processing of user data. Website reports may be incomplete until the issue is resolved. No data will be lost.
Posted May 27, 2022 - 00:14 EDT
This incident affected: RescueTime Web Application and Data Processors.