Data Processing Delays
Incident Report for RescueTime, Inc
Resolved
Thank you for your patience. Data processors are now running as they should
Posted 11 days ago. May 14, 2019 - 13:35 CDT
Monitoring
Our lag time is longer than usual. We are currently monitoring this, please note that no data has been lost and the system should be caught up shortly.
Posted 11 days ago. May 14, 2019 - 12:46 CDT
This incident affected: Data Processors.