Unable to access Site
Incident Report for RescueTime, Inc
Resolved
Users received 503 errors when trying to access the site. Our engineers have resolved the issue. Sorry for the interruption. No data was lost during this delay.
Posted May 24, 2019 - 18:29 EDT
Investigating
Users are receiving 503 errors when trying to access the site. Our engineers are currently investigating. We will keep you updated.
Posted May 24, 2019 - 18:00 EDT
This incident affected: RescueTime Web Application.