Scheduled Database Maitenance
Incident Report for RescueTime, Inc
Resolved
This incident has been resolved.
Posted Jan 13, 2024 - 14:09 EST
Investigating
We will be performing scheduled maintenance and all RescueTime resources will be unavailable for approximately the next hour.
Posted Jan 13, 2024 - 13:15 EST
This incident affected: RescueTime Web Application and Data Processors.