Servers Down

Incident Report for RescueTime, Inc

Resolved

This issue has been resolved. We apologize for the inconvenience.
Posted Dec 19, 2023 - 17:14 EST

Monitoring

Developers have identified the issue and are working on a fix. Users activities have started to appear, we will post an update when the issue has been resolved.
Posted Dec 19, 2023 - 16:19 EST

Investigating

RescueTime servers are currently down, this has caused a back up in activity tracking. Our developers are aware and working on resolving the issue.
Posted Dec 19, 2023 - 10:25 EST
This incident affected: Data Processors.