Server Errors
Incident Report for RescueTime, Inc
Resolved
This incident has been resolved.
Posted Nov 06, 2019 - 19:26 EST
Monitoring
A fix has been implemented and we are monitoring the results. Please let us know at support@rescuetime.com if you are still running into issues.
Posted Nov 06, 2019 - 15:53 EST
Identified
We have identified the issue, and we are taking steps to mitigating the impact. We are working hard to fully resolve this issue.
Posted Nov 06, 2019 - 11:26 EST
Update
The site Rescuetime.com is now accessible. However, investigation is still going on with our servers. Your data has not been lost, however, there will be a delay of it appearing on your dashboard. We will continue to keep you up to date.
Posted Nov 06, 2019 - 07:14 EST
Investigating
We are currently investigating servers errors received when trying to access RescueTime.com. Thank you for your patience.
Posted Nov 06, 2019 - 06:21 EST
This incident affected: RescueTime Web Application.