Service disruption for website user experience - no disruption for data pipeline

Incident Report for RescueTime, Inc

Resolved

Service is restored.
Posted Nov 07, 2024 - 15:49 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 07, 2024 - 15:41 EST

Investigating

Repair is being applied and service should be expected to be restored in 10 minutes.
Posted Nov 07, 2024 - 15:41 EST
This incident affected: RescueTime Web Application.