Site Down
Incident Report for
RescueTime, Inc
Resolved
Users were unable to access RescueTime.com for a bit, but we're back on track now.
All systems are 100% again. Apologies for the trouble!
Posted
Mar
18
,
2019
-
13:18
EDT
Update
We are continuing to investigate this issue.
Posted
Mar
18
,
2019
-
13:00
EDT
Investigating
We realize users are receiving 503 errors when trying to access the site. Our engineers are currently investigating. We will keep you updated.
Posted
Mar
18
,
2019
-
12:59
EDT
This incident affected: RescueTime Web Application.
×
Subscribe to Incident
Subscribe to updates for
Site Down
via . You'll receive .