Disruption in user data processing

Incident Report for RescueTime Inc

Resolved

This incident has been resolved.
Posted May 29, 2026 - 13:09 EDT

Identified

Now recovering with no data loss. It may take up to an hour for data to be updated.
Posted May 29, 2026 - 11:42 EDT

Investigating

We are currently investigating this issue.
Posted May 29, 2026 - 10:52 EDT
This incident affected: RescueTime Web Application.